Claims - Batch Processing Delay

Incident Report for Waystar System Status Check

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 09:05 EDT

Identified

Reason for Notice:
Waystar is currently experiencing a delay in claims batch processing causing submitted batches to process longer than usual.

Action Taken by Waystar:
We are working diligently to resolve the issue and will be monitoring batches to ensure they process as expected.

Action Required by Customer:
None at this time. We apologize for any inconvenience this has caused in your daily workflow.
Posted Oct 10, 2025 - 13:33 EDT
This incident affected: Overall Platform and Waystar Portal Login and Claims Management (Waystar Claims Management).