Pro Patient Payments: Increased Declines

Incident Report for Waystar System Status Check

Resolved

We have identified an issue where payments are declining at higher than normal rates. Our teams have applied mitigation and we are seeing payments process normally.
Posted Nov 10, 2025 - 17:30 EST

Monitoring

We have identified an issue where payments are declining at higher than normal rates. Our teams have applied mitigation and we are seeing payments process normally.
Posted Nov 10, 2025 - 16:59 EST

Identified

We have identified an issue where payments are declining at higher than normal rates. We are working to mitigate the issue.
Posted Nov 10, 2025 - 16:51 EST
This incident affected: Patient Payments (PatientWallet & PatientNotebook, Provider Payments Portal, Epic Integrated APIs).