This issues has been resolved and we are seeing ACH payments return to normal volume. If you continue to see issues with your ACH payments, please open a case through the Support and Training Center.
Posted Jun 02, 2026 - 16:55 EDT
Monitoring
Our upstream vendor has applied a fix and we are seeing successful ACH transactions at this time. Our decline rate has returned to an expected volume.
We will continue to monitor this issue to ensure transactions continue to process as expected.
Posted Jun 02, 2026 - 12:03 EDT
Identified
We are investigating reports of increased declines with ACH transactions. Some payments are processing at this time, but we are seeing a higher than expected decline rate. We are actively working with our upstream vendor to apply a fix. At this time we are only seeing issues with ACH payments. Credit card transactions are not impacted.
Posted Jun 02, 2026 - 10:15 EDT
This incident affected: Patient Payments (PatientWallet & PatientNotebook, Payment Processing).