Our upstream vendor has corrected an issue with an upstream payment processor that is causing an increased rate of Apple Pay transaction failures. Payments ae now processing as expected.
All other payment vectors, including Google Pay, Epic Integration, Terminal and PatientWallet payments are performing normally.
Posted Sep 02, 2026 - 14:00 EDT
Investigating
We are currently investigating an issue with an upstream payment processor that is causing an increased rate of Apple Pay transaction failures. If a patient encounters an error while attempting to pay with Apple Pay, we recommend using an alternate payment method or payment flow while we work to resolve the issue.
All other payment vectors, including Google Pay, Epic Integration, Terminal and PatientWallet payments are performing normally.
Posted Sep 02, 2026 - 10:53 EDT
This incident affected: Patient Payments (PatientWallet & PatientNotebook).