We have identified an issue causing slowness when processing payments through Internet Cashier using manual card entry or encrypted card readers, including devices such as the DynaMag and DynaPad. We have applied a fix to the system.
We are seeing payments process successfully after performing a hard reset on their browser (Ctrl+Shift+R) and clearing cache and cookies.
Terminal payments and Epic-integrated payments are not impacted by this issue.
Posted Aug 05, 2026 - 16:06 EDT
Identified
We have identified an issue causing slowness when processing payments through Internet Cashier using manual card entry or encrypted card readers, including devices such as the DynaMag and DynaPad.
Some users have found success after performing a hard reset on their browser (Ctrl+Shift+R). Terminal payments and Epic-integrated payments are not impacted by this issue.
Posted Aug 05, 2026 - 15:17 EDT
Investigating
We have identified an issue causing slowness when processing payments through Internet Cashier using manual card entry or encrypted card readers, including devices such as the DynaMag and DynaPad.
Some users have found success after performing a hard reset on their browser (Ctrl+Shift+R). Terminal payments and Epic-integrated payments are not impacted by this issue.
Posted Aug 05, 2026 - 10:44 EDT
This incident affected: Patient Payments (Provider Payments Portal, Payment Processing).