Pro Patient Payments- Results not Appearing in Internet Cashier Search

Incident Report for Waystar System Status Check

Resolved

We have resolved the issue in Internet Cashier causing searches for patients or estimates by patient name or account number to return empty results. We have pushed a fix and are seeing searches are working as expected.
Posted Jun 12, 2026 - 10:36 EDT

Update

We are aware of an issue in Internet Cashier causing searches for patients or estimates by patient name or account number to return empty results. Specifically, we have identified that some patient accounts are not appearing in search results.

We have pushed a fix and are seeing some improvements, but are still investigating. We recommend attempting to search by account number when possible while we continue working to restore all search results. Updates will be provided as progress continues.
Posted Jun 11, 2026 - 15:33 EDT

Update

We are aware of an issue in Internet Cashier causing searches for patients or estimates by patient name or account number to return empty results. Specifically, we have identified that some patient accounts are not appearing in search results.

We have implemented a fix for the underlying issue; however, some data is still being restored. We are actively working to return all search results to normal and will provide updates as progress continues.
Posted Jun 11, 2026 - 11:00 EDT

Identified

We are aware of an issue in Internet Cashier causing searches for patients or estimates by patient name or account number to return empty results, and we understand the impact this may have.

Specifically, we have identified that some patient accounts are not appearing in search results and are actively working to restore these results. Our team will continue to provide updates as more information becomes available.
Posted Jun 11, 2026 - 09:41 EDT

Investigating

We are aware of an issue in Internet Cashier causing searches for patients or estimates by patient name or account number to return empty results, and we understand the impact this may have. Our team is actively investigating and will continue to provide updates as more information becomes available.
Posted Jun 11, 2026 - 09:11 EDT
This incident affected: Patient Payments (Provider Payments Portal).