SFTP Navicure integrated (secureftp.navicure.com) Processing Delay

Incident Report for Waystar System Status Check

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 11:32 EDT

Update

We are continuing to monitor for any further issues.
Posted Jun 30, 2026 - 11:32 EDT

Monitoring

Reason for Notice: Waystar is aware of an issue that started yesterday and is causing a delay in SFTP file processing for Navicure integrated (secureftp.navicure.com) clients.

Action Taken by Waystar: We have received the files and are actively working to resolve the issue at a high priority.

Action Required by Customer: None at this time.
Posted Jun 30, 2026 - 10:28 EDT
This incident affected: Claims Management (Waystar Claims Management).