Eligibility - Delayed Responses/Slowness

Incident Report for Waystar System Status Check

Resolved

Response times have returned to normal. We are marking this incident as resolved and will continue to monitor system performance.
Thank you for your patience.
Posted Aug 06, 2026 - 11:32 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 06, 2026 - 11:11 EDT

Update

While service performance has improved, some users may still encounter occasional response delays of up to 30 seconds. Our teams remain engaged in identifying the root cause and implementing a resolution as quickly as possible.
Posted Aug 06, 2026 - 11:06 EDT

Investigating

Reason for Notice:
Waystar Technology Team is currently in the process of reviewing delayed responses/slowness in Eligibility

Action Taken by Waystar:
We are working diligently to research the issue.

Action Required by Client:
None at this time. We apologize for any inconvenience this has caused in your daily workflow.
Posted Aug 06, 2026 - 10:16 EDT
This incident affected: Financial Clearance & Patient Access (Waystar Eligibility, Enterprise Eligibility).