Remits - Unable to access Remits>Payments

Incident Report for Waystar System Status Check

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 09:56 EDT

Monitoring

Reason for Notice:
Waystar is currently experiencing an issue with being able to access Remits>Payments within the site. Users are receiving an error message that states: Error Retrieving Payments

Action Taken by Waystar:
We are working diligently to resolve the issue.

Action Required by Client:
None at this time. We apologize for any inconvenience this has caused on your daily workflow.
Posted Sep 16, 2026 - 09:06 EDT
This incident affected: Claims Management (Waystar Claims Management).