Clinical Integrity + Revenue Capture Incident: Concurrent Webclient/Legacy

Incident Report for Waystar System Status Check

Resolved

The Concurrent Webclient/Legacy component remains fully operational, and this incident is now resolved.
Posted Feb 20, 2026 - 14:31 EST

Monitoring

A fix has been implemented, and the Concurrent Webclient/Legacy component has been restored and is now available. We will continue to closely monitor the service to ensure there are no further disruptions.
Posted Feb 19, 2026 - 22:38 EST

Identified

The issue has been identified, and our technical teams are actively engaged in remediation efforts. Restoring access to the Concurrent Webclient/Legacy component remains our highest priority, and we will share updates as they become available.
Posted Feb 19, 2026 - 11:06 EST

Investigating

Iodine, now a part of Waystar, is currently addressing an issue affecting the Concurrent Webclient/Legacy component. As a precaution, access to this component has been temporarily disabled while we validate system behavior.

Our teams are actively working to restore access as quickly as possible and will provide updates as progress is made.

If you have questions or require assistance, please contact Support through the Help Center or at support@iodinesoftware.com
Posted Feb 18, 2026 - 14:23 EST
This incident affected: Clinical Integrity + Revenue Capture (Concurrent).