Legacy Portal Outage

Incident Report for Waystar System Status Check

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 09:37 EDT

Investigating

Reason for Notice:
Waystar is currently experiencing intermittent slowness when accessing the portal, and in some cases, users may be unable to access it entirely.

Action Taken by Waystar: 
We are working diligently to research the issue. 

Action Required by Client: 
None at this time. We apologize for any inconvenience this has caused in your daily workflow.
Posted Jun 26, 2026 - 09:12 EDT
This incident affected: Financial Clearance & Patient Access (Enterprise Eligibility, Waystar Estimation).