Resolved: Increased Pro Patient Payment Declines

Incident Report for Waystar System Status Check

Resolved

Yesterday we reported that we were seeing an increase in declines for clients using Pro Patient Payments. This issue has been resolved and we are seeing payments processing normally.
Posted Nov 13, 2025 - 10:55 EST
This incident affected: Patient Payments (Provider Payments Portal, Payment Processing, Epic Integrated APIs).