Eligibility - Delayed Responses/Slowness

Incident Report for Waystar System Status Check

Resolved

Issue Start: 3:34 PM ET
Issue End: 3:49 PM ET

During ongoing root cause analysis related to earlier system performance issues, an internal database query inadvertently impacted eligibility processing, resulting in a temporary interruption of real-time eligibility transactions. Once identified, the query was stopped and processing returned to normal.

We apologize for the disruption and appreciate your patience while we worked to resolve the issue.
Posted Aug 06, 2026 - 16:16 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 06, 2026 - 16:02 EDT

Investigating

Reason for Notice: Waystar Technology Team is currently in the process of reviewing delayed responses/slowness in Eligibility

Action Taken by Waystar: We are working diligently to research the issue.

Action Required by Client: None at this time. We apologize for any inconvenience this has caused in your daily workflow.
Posted Aug 06, 2026 - 15:52 EDT
This incident affected: Financial Clearance & Patient Access (Waystar Eligibility, Enterprise Eligibility).