The Introspect application remains fully operational, and this incident is now resolved.
Posted Feb 23, 2026 - 09:27 EST
Monitoring
A fix has been implemented, and Introspect access has been restored and is now available. We will continue to closely monitor the service to ensure there are no further disruptions.
Posted Feb 22, 2026 - 13:10 EST
Investigating
Iodine, now part of Waystar, is aware of an unexpected service disruption that may result in performance issues within your Introspect application instance.
Our team is actively investigating and working to resolve this issue as a top priority.
If you experience additional issues or have questions, please contact our Support team through the Help Center or by email at support@iodinesoftware.com.
Posted Feb 22, 2026 - 11:54 EST
This incident affected: Clinical Integrity + Revenue Capture (Introspect).