Waystar Support Phone Issues 4-4-25

Incident Report for Waystar System Status Check

Resolved

This incident has been resolved. Our phone lines are open and working as expected. We apologize for any disruptions this may have caused you during the brief issues this afternoon.
Posted Apr 04, 2025 - 14:30 EDT

Identified

Waystar is experiencing technical difficulties with our inbound phone system, which may result in challenges reaching a live representative and longer-than-usual wait times.

We are actively working with our phone system vendor to resolve the issue as quickly as possible.

In the meantime, you can open a new support case in the Support + Training Center for assistance.

Thank you for your patience.
Posted Apr 04, 2025 - 13:52 EDT
This incident affected: Overall Platform and Waystar Portal Login.