Pro Patient Payments Delays in Messages and eBills

Incident Report for Waystar System Status Check

Resolved

Processing has returned to normal, and messages and eBills are actively being ingested and processed. Clients may continue to experience slight delays as the remaining backlog is cleared. We will continue monitoring until all queued items have been fully processed.
Posted Aug 07, 2026 - 11:24 EDT

Monitoring

Processing has returned to normal, and messages and eBills are actively being ingested and processed. Clients may continue to experience slight delays as the remaining backlog is cleared. We will continue monitoring until all queued items have been fully processed.
Posted Aug 07, 2026 - 11:01 EDT

Update

We have identified a delay affecting print processing in Pro Patient Payments. Due to this issue, messages and eBills are not processing as quickly as expected and may experience delays before appearing in the system. We are actively working to restore normal processing.
Posted Aug 07, 2026 - 10:31 EDT

Investigating

We have identified a delay affecting print processing. Due to this issue, messages and eBills are not processing as quickly as expected and may experience delays before appearing in the system. We are actively working to restore normal processing.
Posted Aug 07, 2026 - 10:29 EDT
This incident affected: Patient Payments (Provider Payments Portal).