The issue impacting navigation to Patient Payment screens has been resolved, and users should no longer encounter 500 errors or “Oops” messages. We will continue to monitor to ensure stability.
Posted Jun 12, 2026 - 12:52 EDT
Investigating
We are currently investigating an issue where users attempting to navigate to Patient Payment screens are getting a 500 error message or an "Oops" error message.
At this time Pro Patient Payments is not impacted.
Posted Jun 12, 2026 - 12:40 EDT
This incident affected: Patient Payments (Provider Payments Portal).