We have identified an issue causing slowness when processing payments through Internet Cashier using manual card entry or encrypted card readers, including devices such as the DynaMag and DynaPad. A fix has been implemented.
To ensure payments process successfully, please perform a hard refresh of your browser (Ctrl+Shift+R), as cached data may prevent the update from taking effect.
Terminal payments and Epic-integrated payments are not impacted by this issue.
Posted Aug 04, 2026 - 17:54 EDT
Monitoring
We have identified an issue causing slowness when processing payments through Internet Cashier using manual card entry or encrypted card readers, including devices such as the DynaMag and DynaPad. A fix has been implemented.
To ensure payments process successfully, please perform a hard refresh of your browser (Ctrl+Shift+R), as cached data may prevent the update from taking effect.
Terminal payments and Epic-integrated payments are not impacted by this issue.
Posted Aug 04, 2026 - 16:57 EDT
Investigating
We are currently investigating an issue where users are attempting to process payments and are seeing the page move very slowly or freeze on a processing page.
Posted Aug 04, 2026 - 15:27 EDT
This incident affected: Patient Payments (Provider Payments Portal, Payment Processing).