Pro Patient Payments- Increase in Errors when Processing ACH Payments

Incident Report for Waystar System Status Check

Resolved

We have implemented a configuration update, and eCheck (ACH) payments are now processing normally. We apologize for the disruption and will continue to monitor for stability.
Posted Jun 11, 2026 - 12:15 EDT

Investigating

We are currently investigating an increase in errors affecting eCheck (ACH) payment processing. At this time, up to 70% of transactions are declining with the error message: "300 - Invalid eCheck Account Number."
We understand the impact and will share updates as soon as more information is available.
Posted Jun 11, 2026 - 12:00 EDT
This incident affected: Patient Payments (Payment Processing).