Claims - Batch Processing Delay
Incident Report for Waystar System Status Check
Resolved
The issue that was affecting claim batch processing has now been resolved. Claim batches will now process within normal as expected.
Posted Jan 10, 2025 - 15:28 EST
Identified
Reason for Notice:
Waystar is currently experiencing a delay in claims batch processing causing submitted batches to process longer than usual.

Action Taken by Waystar:
We are working diligently to resolve the issue and will be monitoring batches to ensure they process as expected.

Action Required by Customer:
None at this time. We apologize for any inconvenience this has caused in your daily workflow.
Posted Jan 10, 2025 - 12:18 EST
This incident affected: Claims Management (Waystar Claims Management).