Pro Patient Payments- Increased Declines in Epic

Incident Report for Waystar System Status Check

Resolved

From 1:50 PM to 2:45 PM ET, an issue caused some terminal payments processed within Epic to be incorrectly reported as Timeouts. Payment processing remained successful, and affected transactions were recorded as Completed in Waystar. The issue has been resolved, and transaction processing is operating normally.

We will be voiding transactions associated with the erroneous timeout events that occurred during the incident window. Clients can use their reconciliation files to identify and validate affected transactions. Stored card transactions were not impacted.
Posted Jul 30, 2026 - 16:52 EDT

Monitoring

We identified an issue affecting the display of certain terminal payments processed within Epic. The issue is no longer occurring, and transactions are processing normally. During the incident, payments continued to process successfully and displayed as Completed in Waystar, while Epic incorrectly displayed some transactions as Timeouts. We are monitoring to ensure continued stability.
Posted Jul 30, 2026 - 15:46 EDT

Identified

We have identified that the issue is limited to terminal payments processed within Epic. While these payments are successfully processed and appear as Completed in Waystar, Epic may incorrectly display them as Timeouts.

Stored card transactions are not affected.
Posted Jul 30, 2026 - 15:35 EDT

Update

We have identified that the issue is limited to terminal payments processed within Epic. While these payments are successfully processed and appear as Completed in Waystar, Epic may incorrectly display them as Timeouts.

Stored card transactions are not affected.
Posted Jul 30, 2026 - 15:23 EDT

Investigating

We are currently investigating an issue causing payments to process in Waystar, but show as cancelled in Epic.
Posted Jul 30, 2026 - 14:57 EDT
This incident affected: Patient Payments (Payment Device Management, Epic Integrated APIs).