Remits - Processing and Download Delays
Incident Report for Waystar System Status Check
Update
Remit processing has resumed to normal processing times. We will keep this incident open and monitor through the weekend. Thank you.
Posted Jan 17, 2025 - 17:58 EST
Monitoring
We are diligently working to process the backlog of remits and resume normal remit processing. We hope to have everything caught-up and processing as normal by the end of day. Thank you for your patience.
Posted Jan 17, 2025 - 11:27 EST
Identified
Reason for Notice:
Waystar is currently experiencing issues that are causing delays with processing remits and building downloads.

Action Taken by Waystar:
We are working diligently to resolve the issue.

Action Required by Client:
None at this time. We apologize for any inconvenience this has caused on your daily workflow.
Posted Jan 16, 2025 - 18:19 EST
This incident affects: Claims Management (Waystar Claims Management).