Server error and performance issues when accessing Dental claims

Incident Report for Waystar System Status Check

Resolved

Waystar technology has resolved the issues seen with accessing Dental claims.
Posted Mar 19, 2026 - 11:55 EDT

Monitoring

Reason for Notice: Waystar is aware of current issues when attempting to access Dental claims. Some clients are receiving server errors. Others may see that hyperlinks are not present and/or claims are not loading onto the page.

Action Taken by Waystar: Our internal teams are working diligently to resolve the issue .

Action Required by Customer: None at this time. We apologize for any inconvenience this has caused in your daily workflow and we appreciate your patience while we work to resolve.
Posted Mar 18, 2026 - 12:23 EDT
This incident affected: Claims Management (Dental Claims Solution).