Pro Patient Payments- Lane WorldPay Devices Throwing Errors

Incident Report for Waystar System Status Check

Resolved

We have identified the issue impacting Lane Devices on the WorldPay network and are seeing a decrease in related errors.
Lane NMI, PAX, and BlueFin devices continue to operate normally with no impact observed.
Posted Jun 11, 2026 - 11:56 EDT

Monitoring

We have identified the issue impacting Lane Devices on the WorldPay network and are seeing a decrease in related errors.
Lane NMI, PAX, and BlueFin devices continue to operate normally with no impact observed.

Affected Lane Devices on the WorldPay network may still intermittently display a “Connection issue, contact representative” error. Out of an abundance of caution, we are continuing to investigate with our downstream vendor.

We will continue to provide updates as more information becomes available.
Posted Jun 11, 2026 - 11:32 EDT

Update

We have identified the issue impacting Lane Devices on the WorldPay network and are seeing a decrease in related errors.
Lane NMI, PAX, and BlueFin devices continue to operate normally with no impact observed.

Affected Lane Devices on the WorldPay network may still intermittently display a “Connection issue, contact representative” error. Out of an abundance of caution, we are continuing to investigate with our downstream vendor.

We will continue to provide updates as more information becomes available.
Posted Jun 10, 2026 - 16:48 EDT

Identified

We are have identified the issue with a downstream vendor that is impacting Lane Devices on the WorldPay network, and are working to mitigate the issue. Affected devices may display an error message such as “Connection issue, contact representative” and may appear as “Unable to Verify” in the Waystar portal.

Lane NMI devices, PAX devices, and BlueFin devices are not impacted at this time.
Posted Jun 10, 2026 - 16:01 EDT

Investigating

We are currently investigating an issue with a downstream vendor that is impacting Lane Devices on the WorldPay network. Affected devices may display an error message such as “Connection issue, contact representative” and may appear as “Unable to Verify” in the Waystar portal.

Lane NMI devices, PAX devices, and BlueFin devices are not impacted at this time.
Posted Jun 10, 2026 - 13:43 EDT
This incident affected: Patient Payments (Payment Processing, Payment Device Management).