The phone system issues have been resolved by our phone vendor, and are now operating as expected. If you need support, you may continue to call our Support line during normal business hours or open a new case in the Support & Training Center for assistance at any time.
Thank you for your patience as our vendor worked through this unexpected outage.
Posted Mar 31, 2025 - 21:27 EDT
Identified
Waystar is experiencing technical difficulties with our inbound phone system, which may result in challenges reaching a live representative and longer-than-usual wait times.
We are actively working with our phone system vendor to resolve the issue as quickly as possible.
In the meantime, you can open a new support case in the Support + Training Center for assistance.
Thank you for your patience.
Posted Mar 31, 2025 - 16:13 EDT
This incident affected: Overall Platform and Waystar Portal Login.