The previously observed issue affecting the account switch search in the Pro Patient Payments platform is no longer occurring. Errors have ceased, and the platform is operating as expected. We will continue to monitor for stability.
Posted Mar 30, 2026 - 11:30 EDT
Monitoring
The previously observed issue affecting the account switch search in the Pro Patient Payments platform is no longer occurring. Errors have ceased, and the platform is operating as expected. We will continue to monitor for stability.
Posted Mar 30, 2026 - 11:08 EDT
Identified
We are proactively investigating potential slowness related to the account switch search within the Pro Patient Payments platform. While we are not currently seeing error reports, some users may experience delays when switching accounts or searching for patients. Our development teams are reviewing this behavior out of an abundance of caution, and we will continue to provide updates as more information becomes available.
Posted Mar 30, 2026 - 11:07 EDT
Investigating
We are investigating reports of potential slowness within the Pro Patient Payments platform. At this time, some users have reported delays when changing locations or searching for patients. Our development teams are actively reviewing the issue, and we will share updates as additional details are confirmed.
Posted Mar 30, 2026 - 11:03 EDT
This incident affected: Patient Payments (Provider Payments Portal).