Claim Status Plus Report Delivery Delay

Incident Report for Waystar System Status Check

Resolved

This incident has been resolved. Reports will generate as scheduled for tomorrow.
Posted Oct 04, 2025 - 17:22 EDT

Identified

It was identified this morning that daily claim status plus files were not delivered to client SFTP folders. We are currently investigating to determine root cause and fix.

Please be advised that the impact is limited to Claim Status Plus and not Claim Monitoring.
Posted Oct 04, 2025 - 12:33 EDT
This incident affected: Claims Management (Waystar Claims Management).