Pro Patient Payments - Application Offline

Incident Report for Waystar System Status Check

Resolved

Pro Patient Payments and Patient Wallet are fully online and stable.

If you have any additional issues, please contact us through the Support and Training Center
Posted Jun 15, 2026 - 19:42 EDT

Monitoring

We pushed a change on our end and are seeing Pro Patient Payments and Patient Wallet back online.

We will continue to monitor to make sure everything is stable, but all applications are operational at this time.
Posted Jun 15, 2026 - 18:21 EDT

Investigating

We are seeing issues where Pro Patient Payments and Patient Wallet are currently offline. The site will either load indefinitely, or give a technical difficulties error.

We are working to get this resolved and will update you as soon as possible.
Posted Jun 15, 2026 - 18:02 EDT
This incident affected: Patient Payments (PatientWallet & PatientNotebook, Provider Payments Portal, Payment Processing, Payment Device Management, Epic Integrated APIs).