Pro Patient Payments and PatientWallet Intermittent Issues

Incident Report for Waystar System Status Check

Resolved

The issue with our downstream vendor has been resolved. We no longer see errors or site exceptions when trying to process payments.
Posted Nov 18, 2025 - 16:35 EST

Monitoring

Our team has identified the issues with our downstream vendor and has applied a fix. We no longer see errors or site exceptions when trying to process payments. We will continue to monitor the situation.
Posted Nov 18, 2025 - 09:06 EST

Identified

We continue to monitor issues with our downstream vendor and are actively working to mitigate them. We are seeing increased performance with Epic payments and payments keyed in the Waystar portal.

We are still seeing issues with the IVR and the PatientWallet. Terminal transactions in the Waystar portal are not impacted.
Posted Nov 18, 2025 - 08:36 EST

Investigating

Due to an issue with a downstream vendor we are seeing degraded performance with PatientWallet, Keyed Credit Card transactions, and Epic Integrated Payments.

Payments taken in the Waystar portal with a terminal are not impacted at this time.
Posted Nov 18, 2025 - 07:02 EST
This incident affected: Patient Payments (PatientWallet & PatientNotebook, Payment Processing, Epic Integrated APIs).