Pro Patient Payments: Intermittent Epic and API Payment Errors

Incident Report for Waystar System Status Check

Resolved

The recent errors affecting payment processing through Epic, API integrations, and PatientWallet transactions via Google Pay have been resolved. We are no longer seeing any related issues.
Please note that Internet Cashier payments were not impacted during this incident.
Posted Nov 20, 2025 - 17:06 EST

Monitoring

The recent errors affecting payment processing through Epic, API integrations, and PatientWallet transactions via Google Pay have been resolved. We are no longer seeing any related issues.
Please note that Internet Cashier payments were not impacted during this incident.
Posted Nov 20, 2025 - 15:32 EST

Investigating

We are currently investigating an increase in errors affecting payment processing through Epic and via API integrations. Additionally, we have identified issues with PatientWallet transactions made using Google Pay.
Please note that Internet Cashier payments are not impacted at this time.
Posted Nov 20, 2025 - 14:32 EST
This incident affected: Patient Payments (PatientWallet & PatientNotebook, Epic Integrated APIs).